1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

web3 api in eth

Discussion in 'Programming/Internet' started by S.Bhaskar, Oct 8, 2018.

  1. S.Bhaskar

    S.Bhaskar Guest

    Since, I am not able to use the go client in the multi node mode due to a bug (Multi node private local ethereum and send transaction), I tried to use the c++ client eth. Tried using the go client attach to the instance and cannot seem to execute any web3 commands like in geth.

    Started a test node using:

    eth --datadir ./data/test -j --no-ipc --json-rpc-port 8081 -a <coinbase-addr> --client-name 'test' --listen-ip 127.0.0.1 --listen 30001 --network-id 12321 --no-discovery

    Connect using: geth attach rpc:http://127.0.0.1:8081

    When try admin.nodeInfo or personal.listAccounts, get errors:

    admin.nodeInfo
    ReferenceError: 'admin' is not defined
    at <anonymous>:1:1


    personal.listAccounts
    METHOD_NOT_FOUND: The method being requested is not available on this server
    at web3.js:3119:20
    at web3.js:6023:15
    at get (web3.js:5923:38)
    at <anonymous>:1:-1


    Any help appreciated.

    Login To add answer/comment
     

Share This Page