1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Using Arduino UNO for uploading a sketch to the Espresso Lite v2

Discussion in 'Programming/Internet' started by beppe9000, Oct 8, 2018.

  1. beppe9000

    beppe9000 Guest

    I am trying to use my Arduino UNO as a programming interface to load sketches on the Espresso Lite v2.

    I followed the instructions to setup the Wifi network (long press gpio13 and the AP thing), but now I want to run code on it.

    I uploaded this sketch to the UNO, in order to allow for serial communication(i chose method 3): void setup(){ pinMode(0,INPUT); pinMode(1,INPUT); } void loop(){ }

    Afterwards I configured the Arduino IDE with the necessary libraries and device manager plugins for the Espresso, so I selected "Espresso Lite 2.0" as the target board and for programmer "Arduino as ISP".

    This is what my tools menu looks like:

    [​IMG]

    I connected the 3.3V, GND, TX (to TX) and RX (to RX) and RESET (to RST) headers from the Arduino UNO to the Espresso Lite holes. If I open the Serial Monitor I can see serial output so I think the connections are correct.

    I tried to upload an empty sketch and i got these errors (verbose upload): Sketch uses 246096 bytes (23%) of program storage space. Maximum is 1044464 bytes. Global variables use 27588 bytes (33%) of dynamic memory, leaving 54332 bytes for local variables. Maximum is 81920 bytes. C:\Users\Administrator\AppData\Local\Arduino15\packages\esp8266\tools\esptool\0.4.13/esptool.exe -vv -cd ck -cb 115200 -cp COM3 -ca 0x0 -cz 0x400000 -ca 0x00000 -cf C:\Users\ADMINI~1\AppData\Local\Temp\arduino_build_89/sketch_oct08a.ino.bin esptool v0.4.13 - (c) 2014 Ch. Klippel <ck@atelier-klippel.de> setting board to ck setting baudrate from 115200 to 115200 setting port from COM1 to COM3 setting address from 0x00000000 to 0x00000000 setting erase size to 0x00400000 setting serial port timeouts to 1000 ms opening bootloader resetting board trying to connect flush start setting serial port timeouts to 1 ms setting serial port timeouts to 1000 ms An error occurred while uploading the sketch flush complete espcomm_send_command: sending command header espcomm_send_command: sending command payload read 0, requested 1 trying to connect flush start setting serial port timeouts to 1 ms setting serial port timeouts to 1000 ms flush complete espcomm_send_command: sending command header espcomm_send_command: sending command payload serialport_receive_C0: 0D instead of C0 trying to connect flush start setting serial port timeouts to 1 ms setting serial port timeouts to 1000 ms flush complete espcomm_send_command: sending command header espcomm_send_command: sending command payload serialport_receive_C0: 45 instead of C0 resetting board trying to connect flush start setting serial port timeouts to 1 ms setting serial port timeouts to 1000 ms flush complete espcomm_send_command: sending command header espcomm_send_command: sending command payload read 0, requested 1 trying to connect flush start setting serial port timeouts to 1 ms setting serial port timeouts to 1000 ms flush complete espcomm_send_command: sending command header espcomm_send_command: sending command payload serialport_receive_C0: 0D instead of C0 trying to connect flush start setting serial port timeouts to 1 ms setting serial port timeouts to 1000 ms flush complete espcomm_send_command: sending command header espcomm_send_command: sending command payload serialport_receive_C0: 74 instead of C0 resetting board trying to connect flush start setting serial port timeouts to 1 ms setting serial port timeouts to 1000 ms flush complete espcomm_send_command: sending command header espcomm_send_command: sending command payload read 0, requested 1 trying to connect flush start setting serial port timeouts to 1 ms setting serial port timeouts to 1000 ms flush complete espcomm_send_command: sending command header espcomm_send_command: sending command payload serialport_receive_C0: 0D instead of C0 trying to connect flush start setting serial port timeouts to 1 ms setting serial port timeouts to 1000 ms flush complete espcomm_send_command: sending command header espcomm_send_command: sending command payload serialport_receive_C0: 45 instead of C0 warning: espcomm_sync failed error: espcomm_open failed

    This is the serial output after i tried to upload:

    [​IMG]

    What am I doing wrong?

    Login To add answer/comment
     

Share This Page