1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Macbook Pro (late 2011 15") is stuck in a boot loop

Discussion in 'Programming/Internet' started by Bartholomaios, Oct 8, 2018.

  1. It boots up until the progress bar is at about 80%, then it flashes to an empty grey screen, no login window shown, no Apple logo. 30 seconds later it reboots on its own.

    Things I tried:

    • reset the PRAM/NVRAM
    • reset SMC
    • booted with d+shift: no indication of any kind of different boot, same as normal boot
    • booted with cmd+r: it doesn't boot to the recovery window, but switches to "Internet Recovery". Internet Recovery runs to 100% before switching to the grey screen
    • ran Apple Hardware Test (quick and extended): no failures
    • tried to boot from an "Install Sierra" USB pendrive: it recognizes the pendrive, but boots with the same behavior as a normal boot
    • booted to single user mode: I can boot to Single User mode and run fsck on the different partitions. I cannot repair user permissions (thanks, Apple, for removing that functionality).
    • booted with a live Linux USB-stick: it works, although I have to enter the boot option "nodmraid". However, I cannot start Xorg. I can ssh into the MacBook when booting with Linux. I also ran testdisk and recovered (at least I think so) the partition table. Both, the normal Mac partition, as well as the Recovery Partition are there.
    • booting to verbose mode.

    Some errors occur:

    task_exceeded_footprint: failed to warn the current task...


    AppleKeyStore: operation failed (pid: 45 sel: 7 ret: e00002c2....


    configureInterests - nElements <= 0!Failed to configure interests
    I080211Controller:addSubscriptionForThisReporterFetchedOnTimer() Failed to addSubcription

    I080211InterfaceMonitor::configureSubscriptions() failed to add subscription


    and it finally stops at

    IOConsoleusers: gIOScreenLockState 3, hs 0, bs 0, now 0, sm 0x0


    Any help is appreciated. Does this mean it has a dead GPU? I just found out that Apple's repair program ended in December 2016...

    Login To add answer/comment
     

Share This Page