1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Laravel + l5-repository

Discussion in 'Technology' started by Tonico, Oct 8, 2018.

  1. Tonico

    Tonico Guest

    Caros, estou tentando instalar o l5-repository e dou o comando:

    composer require prettus/l5-repository

    e aparece o seguinte:

    Using version ^2.6 for prettus/l5-repository
    ./composer.json has been updated
    Loading composer repositories with package information
    Updating dependencies (including require-dev)
    Nothing to install or update
    Generating autoload files
    > Illuminate\Foundation\ComposerScripts::postUpdate
    > php artisan ide-helper:generate
    A new helper file was written to _ide_helper.php
    > php artisan ide-helper:meta
    A new meta file was written to .phpstorm.meta.php
    > php artisan optimize
    Generating optimized class loader
    The compiled class file has been removed.


    Porém quando rodo php artisan, só aparecem estas opções:

    make
    make:auth Scaffold basic login and registration views and routes
    make:command Create a new Artisan command
    make:controller Create a new controller class
    make:event Create a new event class
    make:job Create a new job class
    make:listener Create a new event listener class
    make:mail Create a new email class
    make:middleware Create a new middleware class
    make:migration Create a new migration file
    make:model Create a new Eloquent model class
    make:notification Create a new notification class
    make:policy Create a new policy class
    make:provider Create a new service provider class
    make:request Create a new form request class
    make:seeder Create a new seeder class
    make:test Create a new test class


    Já coloquei a linha no config\app.php

    Prettus\Repository\Providers\RepositoryServiceProvider::class

    E quando vou rodar a linha abaixo, vem o erro:

    php artisan vendor:publish --provider="Prettus\Repository\Providers\RepositoryServiceProvider"
    Nothing to publish for tag [].


    Não sei mais o que fazer. Será que conseguem me ajudar ?

    Um abraço Tonico

    Login To add answer/comment
     

Share This Page