1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

5V Pin and i2c (GPIO Expander MCP23017) acting VERY strange

Discussion in 'Programming/Internet' started by JonasAnon, Oct 8, 2018.

  1. JonasAnon

    JonasAnon Guest

    This is the case, I've got an MCP23017 IC to expand the outputs on the Raspberry Pi 2 as the others are going to be used (A0 A1 and A2 connected to 0V and RESET pin connected to 5V). Here are the problems:

    When i first tested my IC today, it didn't work anymore, but 30seconds later when i tried again, it worked correctly. This was strange and i saw that only 3.8V was delivered in total to the IC, which should be 5V. And while it was still working, 2minutes later, it changed again to 5V.

    From a specific moment, everything stopped working, i tried 2 other MCP23017 ICs which also didn't work. It wouldn't show up the expander when doing:

    i2cdetect -y 1


    Almost an hour later, after testing everything in parts, nothing changed actually, tested it and didn't work again, then i tried again and it strangely enough worked again (again it only gave 3.8V!), one thing i noticed now is that the IC became hot so i shutted down the RPi 2 correctly and turned the power of.

    Other notes: when it didn't work, it also sometimes gave 3.8V and sometimes gave 5V, and the IC also became hot. And when it did work, it's exactly the same story.

    This is a picture of the situation, (might the wood be giving the problem?? idk): http://i65.tinypic.com/20foj02.jpg

    I hope you can help me out, as i really don't want to be struggling with this. Any hints/tips/possible explenations are very welcome!

    Kind regards, Jonas

    Login To add answer/comment
     

Share This Page